wi fi - Can't access internet but I'm connected to wifi.

21
2014-04
  • Reuben Castain

    I have been using my dorms WiFi forever -- but since the latest system update on my S3, it won't get internet even though im connected to the WiFi (status says I'm connected -- but the icons in the notification areas stay white). Its like that all over campus. Other places I can use the WiFi without any problems.

    Immediately after the mentioned update, internet worked for one more day on my phone in my dorm, but after that only other WiFi networks seem to work for me.

    I have no idea what the reason could be. Any ideas what I should look for?

  • Answers
  • Sergey Vlasov

    Have you tried dialing *#*#526#*#* ?

    It fixed a wifi connection problem I had.

    I dialed it on the phone, got the "call cannot be completed" message. Hung up, restarted the phone, then went through the whole phone call again.

    It worked. My wifi problem is fixed. I kid you not. Google it. I hope this helps.

  • hackus

    Have had the same issue on my droid 2.3.6. It used to connect to wifi but could not browse the internet until I disabled:

    Parental Control

    from my wifi router.

    Hope this will help someone.


  • Related Question

    wi fi - Internet not accessible even though connected to local network using wifi
  • I-M-JM

    I have a wifi connection setup at my home. Other devices like my ubuntu laptop and macbook, when connected to wifi are able to access internet. Even my dad's blackberry is able to load websites when connected to internet via our home wifi. My HTC desire is able to connect to wifi, shows a good signal, but is not able to connect to internet. My friend's android phone have same issue. I can access a website running on my ubuntu (apache) using my browser and ip assigned to my ubuntu box, but I cannot open google or any other website. Even marketplace show connection error.

    Can someone help me out with this.


  • Related Answers
  • Lohoris

    Did you try setting manually the IP+DNS, instead of relying on DHCP, as it does by default?

    Wireless and Networks -> Wi-Fi settings -> [menu] -> Advanced -> Use static IP

  • Ryan Conrad

    Are you using IPv6 on your router? There was a question here just the other day, that identified an issue with android resolving an IPv4 address when it has an IPv6 address.

    Here is the post I am referring to. If you can, set your router to use IPv4 (for now).