Galaxy Note II USB connection not working

24
2014-04
  • Greg

    On my Galaxy Note II (android 4.1.1), any time I try to connect to something over USB, it doesn't seem to want to connect. Specifically:

    -iSyncr gives me errors connecting; so does Android File Transfer

    -DoubleTwist and EasyPhoneSync can't connect at all

    -Odin gets stuck at "Making Connection" (or something, I can't remember the exact wording)

    These problems occur whether I have USB debugging on or not, and still persist when I mess around with the MTP/PTP settings. Does anyone have any idea what might be wrong? iSyncr used to work fine, but the others have always been broken.

    Note: this is on a mac, and Odin is run through a virtual machine

  • Answers
  • t0mm13b

    What version of Android?

    As of JellyBean 4.2.2, you'd need a newer version of ADB, as there's a security implementation built into JB 4.2.2, in that, any "unauthorised" computer with USB cable plugged in, will show the device as offline, rendering any file transfer/copying etc useless.

    With the new version of ADB as downloaded from Google or for your device, you will be prompted to request authorisation and to allow it, based on a cryptographic key generated by ADB so that the computer is "trusted", then the contents can be copied/transferred.


  • Related Question

    Why doesn't my Samsung Galaxy S communicate via USB?
  • Henno

    I discovered today that I cannot connect my PC with Samsung GT-I9000 any more: when I plug in the microUSB cable, nothing happens other than that the phone starts to charge. Earlier I got to see Connect to Kies or something like that.

    Things I've tried so far:

    -Switcing USB debugging on and off
    -Removing battery
    -Trying different cable
    -Trying reimaging PC to a known good state (where I previously would have found new hardware)
    -Trying different computer
    -Factory data reset
    -Formatting internal SD card
    -Entering download mode with mUSB jig (my phone has download and recovery modes disabled otherwise) and reconnecting mUSB cable. Then I saw the "USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned..." error on Windows (XP).

    Is there anything else I could try before sending it to the long journey of Warrantyland?

    UPDATE: I tried an app z4root which rooted the phone without the need of usb cable, then I could use Rom Manager to force the phone into Recovery Mode (remember my phone had the 3-button combo disabled). There I deleted-erased-formated everything I could and when I got back to normal mode and tried connecting again, Windows found new hardware and Kies recognized the phone. Just to be sure, I pulled the cable from computer, waited for 2 secs and then reconnected but, alas, nothing happenend again. I reimaged the PC and redid the z4root+Rom Manager+Recovery Mode wipe thing but nothing. Then I tried to reinsert microusb plug into phone under an angle and witnessed a successful connection. Kies offered updating firmare. I did not breathe on the phone and carefully clicked mouse to accept in hope that if this was a software error, new update would fix it. The update went fine but after the phone rebooted and I could confirm the firmware version from About, I still could not connect.

    Then I used USB jig which I purchased from eBay to force the phone into download mode and tried to connect it with a PC once again. The PC froze at once (even the mouse cursor did not move). I tried pressing every conceiveable keyboard combination from Enter to Ctrl+Alt+Del and then disconnected the USB cable. As soon as I did that, everything started moving again on the screen. I could reproduce this behaviour for 5 times. On the sixth time, however, Windows found new hardware and started installing drivers but soon after that a balloon popped up saying "USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned [...]". Then I rebooted the phone and came back to the issue later.

    I forced the download mode once again and plugged the USB cable in. Nothing happened. No frozing, no error.

    Even though I have tried to wiggle the microusb plug in from every possible angle, it does not seem to have any effect. It just works when it wants to work. Charging works always, though.


  • Related Answers
  • Swapnil Sonar

    I have followed the Exact steps from Link :

    1. Samsung mobile MTP Device cannot be installed

    2. StackOverflow tutorial

    Here are steps : (for Windows specific instructions):

    1. Ensure phone is not connected to PC.

    2. Uninstall KIES from PC. Reboot your PC and Reinstall KIES after that. Just for great measure... open KIES, go to Tools | Troubleshoot connection error. Follow instructions and wait for it to finish the troubleshooting procedure.

    3. Reboot your phone (or turn off and then on your phone again). Do not connect it to your PC just yet.
    4. Once rebooted, go to your phone's dialer, type *#7284# - A configuration window will appear. In that window's USB section, if it's default to PDA, tap MODEM, then back to PDA, (if it is MODEM in the beginning, change it to PDA) then press the back key to exit. Most importantly, it must set as PDA when you exit.
    5. Turn off USB debugging in your phone.
    6. (Optional) Set your phone's screen timeout to a lengthy time. (minimum 1-2 minutes - recommended 5mins to 30mins) its found in Settings | Display. You can change this back later on.
    7. Connect the phone to your PC with USB cable and let windows load your drivers... and wait for the drivers to get reinstalled.
    8. Once reinstalled, disconnect the phone off USB. Switch USB debugging back on in your phone settings, and reconnect the phone back - you'll see windows load another set of drivers for your phone. Wait until it is completed. (This step is a precautionative measure to ensure your phone is identified with all the necessary drivers)
    9. Once complete, unplug your phone, and turn off USB debugging... This is to ensure MTP will initialize. Also, press the phone's home key until your homescreen is displayed. Only after doing all that, reconnect your phone back to PC.
    10. Test and see if MTP works using Windows Explorer. You'll see your phone's USB storage and SDCard contents if it does.

    Hope it will help you..

  • Matthew Read

    I'd try uninstalling all your drivers/software for the phone, rebooting, reinstalling the official drivers from samsung.com/uk, and trying again. You could also just install the drivers on another computer that has never had the phone connected, to ensure it starts in a clean state. If that doesn't work, I would guess a trip to Warrantyland is required.

  • gbjbaanb

    I had similar problems with mine - plugin on USB, it would charge but do nothing else. It wouldn't even recognise the phone was attached to install drivers.

    After some internet searching, I was ready to give up... but I tried on a different USB port... and more importantly, used an old usb cable from my old phone. Suddenly all sprang into life! So my suggestion is to try a different cable, I think cheap cables are not all made equally.

    Charging worked with either cable, butif the PC knows something is plugged in and istalls the drivers then this is not likely to be your problem, unless you have a dodgy connection in there somewhere.

  • Lindsay Mason

    I had a simular problem, it was caused by moisture getting into the terminals while using phone in the rain. terminals need to be cleaned or replaced

  • Edelcom

    I will give here a solution which I found when I had a similar problem (note: this answer was already given in this question). It really took me some time to find this solution, and to be honest, I seem to be the only one with this problem/solution, but maybe it helps other:

    -- my answer to a similar question on this site --

    I had a similar problem when I still had my PALM synchronization software installed. For some reason or another, it used COMM port 4 for it's communication ( don't know why but it did ), and that conflicted ( probably behind the scenes ) with the communication with my Galaxy S.

    Once I uninstalled the PALM synchronization software, the connection went fine.

    So please check if on your pc some sort of other communication device is installed.

  • irina

    I tried everything too. But after a while, I had to install a fresh version of Windows 7 and to my surprise, Samsung Galaxy S connected with USB.