Galaxy S3 stuck on boot loop, Factory Reset didn't work

25
2014-04
  • Julian

    My Samsung Galaxy S3 (GT-I9300) was rebooting itself for the past few days, randomly. Today, it did it again, but didn't boot back up. Instead, it is now stuck on an infinite boot loop - it gets as far as the splash screen (Galaxy SIII logo), then reboots, and this goes on forever, until I remove the battery.

    The first thing I tried was to remove the battery, SIM card and MicroSD card for 5 minutes. I then wiped the Cache Partition through the Android Recovery Mode. I then did an Emergency Firmware Recovery through Samsung Kies. This didn't help - the phone is still on the same boot loop. I then tried a Factory Reset through the Android Recovery Mode. This also didn't help.

    I tried to view the boot logs through the Android SDK tools, but of course, the phone won't stay on for long enough to connect via USB. I'm not sure what else to try. Is there any other way I could possibly access the device's logs? Or should I try Odin instead of Kies?

    Update: my S3 was had the official stock firmware on it, with official OTA upgrades, it was never rooted.

    Second update: I've now tried flashing with Odin3. I used the firmware version appropriate for my region and carrier. Everything was successful, but I'm still having the same problem. I'm guessing there's not much else left to try except bring the device back to the dealer? ...

  • Answers
  • fifo

    I had same problem with logo loop.. I somehow screwed my EFS folder, but don't actually know how... Anyway I tried like 150 different thinks to fix it that I googled out but non of it worked for me.. Finaly I download orignal stock ROM but the old one with 4.0.4 android. Flashed via ODIN and only then get rid of logo loop and phone turned on normally (it took allmost 5 mins..) Then I restored my EFS folder. Than rooted the phone, installed CWM and made nandroid restore of my original ROM.. Not sure if this help, but saved my ass :) Wish you good luck

  • GuestPerson

    It could be the power button is stuck or dirty. you will need to open the phone and clean the power button. If you don feel comfortable doing this take it to you carrier. I had the same issue and this was my fix.

  • 4L3J4NDR01D

    Try removing the power button. I had the same problem and saw on a youtube video that changing the power button was a good solution. As I could not find a spare power button on, I just decided to remove it and it actually worked! https://www.youtube.com/watch?v=pQ-U-Q_NdOo

  • geffchang

    I had the same bootloop problem on T999 UVDLJA. I tried about 100 solutions, including flashing every possible ROM known and unknown.

    Finally, the solution was very simple:

    • ODIN CWM
    • Flash ROM + Gapps
    • wipe cache, data, dalvik cache
    • install ROM
    • install Gapps (this is the part which I would always skip for later - BIG mistake as Gapps missing caused the boot loop)
    • restart, et voila!!!!
  • geffchang

    I replaced the power button, and it solved the problem.

  • Akhil

    Install any CWM Recovery on the device, and it will work.


  • Related Question

    Desire stuck in Boot Loop After mod install
  • tom

    I installed an Audio Mod 'BeatsAudio' through clockworkmod recovery on my HTC Desire. After i rebooted it just keeps looping the boot logo over and over. I have tried removing the battery, sim and SD card, and also no luck there.

    I've also tried wiping the data and cache partition but that doesn't help. I can get in the HBOOT menu but unrevoked doesn't seem to recognize my phone. I have tried ropening a stock boot rom to see if that would install it but it tells me its not compatible with my 64Bit OS.

    I have no idea what else to do.


  • Related Answers
  • Penguinolog

    You installed Mod to system, so you need to reflash ROM from recovery.

    Erase user data (hard reset) will not help you.

  • adi

    wipe dalvik cache after wiping cache reboot and wait a while