wi fi - Galaxy S3 won't connect to WiFi

19
2014-04
  • djechelon

    I have a Galaxy S3 and a data plan.

    I prefer using wifi whenever possible.

    I tried to connect to a few networks, both private and public but I always get the same result: phone will say "connecting..." or "obtaining IP address..." without actually connecting.

    Restarting the phone won't work. Simply restarting wifi won't work.

    A filtered log of "WiFi" is available here. I used LogCat for it. I also tried to disalbe DroidWall but didn't help. I don't remember what I have done before this occurred. Last option would be formatting phone and restoring TitaniumBackup

    Any idea on how to connect again to home and other networks?

    [Edit] It looks like the device connects only to one or few networks.

    I have a Vodafone Station 2 router at home. I usually keep the built-in wifi disabled. When I enabled it, I was able to connect the phone to it.

    I thought this could have been related to the installation of the Vodafone Station 2 app on the very beginning. My suspects become clear when the device is able to connect only to a Vodafone-xxx network but I have wiped the device. I have tried to connect the device during Android configuration without success.

    [Edit] This suggests to me that it's a hardware problem. After upgrading to stock 4.1.2 I don't get the same error as before (good news) but instead it repeatedly refuses the WPA2 password for the home network. To be precise: I did the Vodafone-test only after upgrading ROM.

    The Vodafone Station 2 router features wifi 802.11 a/b/g/n where my plain old home router only supports b/g. I have tried to configure Station for b only just to see if the device stopped connecting. I have no means of stripping Vodafone prefix from SSID in VS2 router

    [Edit] Anyway I have another log. I don't want to separate myself from my device for too long. I'll try to install the stockest ROM for GS3 and to update via OTA.

    Here are the logs: http://pastebin.ca/2317414 http://pastebin.ca/2317416

    Notable line

    02-26 20:30:03.880 E/WifiHW  (17931): Unable to open connection to supplicant on "/data/misc/wifi/sockets/p2p0": Connection refused
    

    But I'm not using Wifi Direct!!!!!!!!!!

    [Edit] notable line after reverting to oldest stock ROM

    I/wpa_supplicant( 6982): CTRL-EVENT-ASSOC-REJECT bssid=2C.DA.82 status_code=16
    

    [Edit] striked the Vodafone part. Simply the phone connects to the router if you are a few centimetres from it. If you get past about a metre's treshold the phone won't connect. This seems to be a widespread problem affecting Samsung devices, especially Nexus for what I have seen so far.

  • Answers
  • Izzy

    But I'm not using P2P! => P2P in this context is not meant in the sense of "peer-to-peer file sharing". It's a type of socket communication -- think of it as "point-to-point": one point is your device, the other might be the/your router where it should connect to.

    The error message you quoted can be found in the Android code of wifi/wifi.c, in a part suggesting it's a WPA issue (I'm not an Android programmer, so I cannot tell for sure). Your problem was e.g. also reported in a German post at AndroidPIT (Google-translated variant). The reporter there found an easy solution: Resetting the router solved it for him.

    In case this doesn't work for you, more information might be found using this Google search.


  • Related Question

    wi fi - Samsung Galaxy S3 Wi-Fi problems
  • Danielle

    My Samsung Galaxy S3 has major Wi-Fi problems. It will connect to Wi-Fi for a few seconds, then it quits and won't connect to anything. It happens at home, work, or anywhere else with Wi-Fi. It's not the router. My laptop and other phone works fine with it.

    If I turn off the Wi-Fi and then turn it back on again, it will work for a little while, but then, nothing, no connection to anything. I've researched the problem for days and seems like a lot of people are dealing with the same thing.

    There are some supposed 'quick fixes' but none work for me. (dialing *#0011# on the phone to turn off power save mode, downloading a Wi-Fi Fixer app, doing a factory reset, trying to set a static IP - phone won't let me, and everything else, NOTHING WORKS!).

    Is this a problem with the phone or the software? Do I need to exchange the phone for a different one?

    I even called Samsung and they claimed that no one else has ever reported a problem with this, even though there are hundred and hundreds of posts online about the issue.

    Is Samsung doing anything about this or should I just give up and get a different phone all together? By the way, it always says that I am connected to Wi-Fi. It just doesn't actually work.

    I've read about having to set the router to G or N but I have no idea what the means or how to do it? And besides, why should I have to do that? Shouldn't the phone's wi-fi just work? And how would I do this G or N setting at work? Not gonna happen, so I'd be outta luck there.

    So frustrating!!


  • Related Answers
  • garettmd

    If you're using the Sprint version of the S3, see if Sprint Connections Optimizer is turned on under Settings > More Settings > Mobile Networks. Make sure it's turned off, as it can cause Wi-Fi to be a little funky sometimes.