How to boot to ClockworkMod recovery with Galaxy5 GT-i5500

16
2014-04
  • ArtDeineka

    I have ClockworkMod recovery installed on a phone (Samsung Galaxy5 GT-i5500, I have used it in the past to flash ROMs).

    The phone is currently not booting, just shows the Samsung logo.

    I want to get into the ClockworkMod recovery mode, by pressing some key combination. (Do not confuse with Samsung download mode: power-down+middle-button+power.)

    How to get to CWM recovery mode?

  • Answers
  • ArtDeineka

    It is impossible to boot directly into CWM recovery by key combination. However one can boot into "download mode" (as described in question) and then (re)flash recovery with Odin, this will automatically reboot phone to CWM recovery


  • Related Question

    rom flashing - Why isn't Clockworkmod Recovery "Sticking"?
  • Wesley Wiser

    I've tried multiple times to flash ClockworkMod recovery onto my unlocked Galaxy Nexus (LTE\CDMA variant "toro" build) device. Each time I can boot into recovery and ClockworkMod displays. However, if I completely reboot my device (boot into Android and then reboot), when I try to run recovery, my phone shows an android with a red exclamation point and refuses to boot. I've tried flashing from both Linux with the fastboot tool as well on the device itself with ROM Manager. ROM Manager reports that ClockworkMod 5.5.0.4 is flashed.

    What am I doing wrong?


  • Related Answers
  • Malachi

    I had the same problem and I found the solution is to rename a file in the system folder:

    • remount /system in read/write mode (use something like the Root Explorer app or ES File Explorer; both have root modes (check the app's settings) for remounting /system as writable)

    • rename the /system/recovery-from-boot.p to /system/recovery-from-boot.p-bak

    (note: you could delete it, but renaming is much safer since its easily reversible)

    you could also do this manually in an adb shell or on-phone Terminal session:

    • mv /system/recovery-from-boot.p /system/recovery-from-boot.p-bak

    • after you've renamed the file, you might have to re-flash your CWM if it had been missing previously

    http://androidforums.com/galaxy-nexus-all-things-root/470831-how-all-things-root-samsung-galaxy-nexus.html#post3712027