"Incompatible with other applications(s) using the same shared user ID" when installing Google Play service?

18
2014-04
  • Charlie

    I need to run Google Plus, and Google Plus needs the Google Play service.

    Every time I install google play service from the Google Play store it fails to install with this error:

    Incompatible with other applications(s) using the same shared user ID

    What could be the issue? How can I fix this?

    UPDATE: I know almost nothing about android, so I dont know what ROM is, or such thing, I get my phone from local production and I guess, yes, it uses custom system, so I just know that I'm using Android Version 4.0.4. any help would be greatly appreciated.

  • Answers
  • t0mm13b

    What is get my phone from local production?

    Since you mentioned about custom system are you referring to a modded ROM like Cyanogenmod, Paranoid Android etc?

    You have custom recovery in place? If so, grab the latest Google Apps from here appropriately for Android 4.0.4 aka ICS, more than likely, this version of gapps.

    Reboot into Recovery, select:

    • Wipe Cache
    • Install from zip, select the gapps you downloaded
    • Then when install is done, reboot.
  • Sid

    Google Play services is used to update Google apps and apps from Google Play. This component gives you access to Google Settings and helps apps speed up offline searches, provide more immerse maps, and improve performance.

    If you think there is an error of your OS, you can always go for a factory reset. You shall backup your data before you proceed. This should re-install the Google Play service. And if you are NOT asked to install Google Play Services, you don't have to. It is bundled with your OS. You must simply be able to download Google+ and use it on your phone.

    You can find your device info from Settings => About Phone

  • Daniels

    I had the same problem. I uninstalled all app updates and this fixed the issue

  • Joel Coehoorn

    What worked for me was the suggestion I found here:

    http://forum.xda-developers.com/showthread.php?t=1219029

    In a nutshell:

    1. Figure out the exact formal fully-qualified package name or *.apk name for the app you're trying to install. For Google Play Services, it's com.google.android.gsf or GoogleServicesFramework.apk.
    2. Pull the /data/system/packages.xml file from the phone using adb
    3. Open the xml file in a text editor and look for the <package> xml element that describes your app, using the names from step 1.
    4. Get the value of the sharedUserId attribute for that element.
    5. Remove the entire <shared-user> xml element with the userId attribute that matches the id you found for the packate.
    6. Push the packages.xml file back to same location on the phone using adb
    7. Wipe the dalvik cache and reboot.
  • Jatin Malwal

    You should know this first that Google play service is required by some apps which had implemented functionality provided by google play services. Like multi player, real time multi player, leader-boards, achievements in some games ans apps.

    If you are having problem in downloading it there are many possible solutions there. - Go to the application manager, remove all updates from google+ related apps. Then start play service after installing all the apps updates. This might get solved ur problem.


  • Related Question

    2.2 froyo - Can't install Google Play Services
  • Philip Durbin

    I just upgraded Google+ to 3.6.0.44338848 (released late March 2012) and now it won't launch. It says:

    This app won't run without Google Play services, which are missing from your phone.

    If I tap "Get Google Play services" I'm brought to Google Play where I tap "install" and "accept and download" but then I get "Error: No connection."

    (I do have a connection. I can browse the web just fine.)

    Now, I should mention that Market/Play has been odd the whole time, I've had this phone, a T-Mobile myTouch 4G running Android 2.2.1. Whenever I want to install an app, I have to go into Applications, tap Google Play Store, and tap "Uninstall updates" to restore the Market app. Then I can install applications. Over time, some process upgrades Market to Google Play but I can't install applications until I downgrade to Market to avoid the "Error: no connection" message. The processes is frustrating. On my old LG phone (also running 2.2 Google Play worked just fine).

    I'm been putting up with all this downgrading because it's not often I install apps and usually there's no problem after installing or upgrading an app.

    But now the Google+ app is unusable so I'm motivated to do something about the "No connection" problem.

    I've read through posts such as http://www.teamandroid.com/2013/01/14/fix-google-play-store-no-connection-retry-error-message/ and Google's help page at How to access the Google Play Store app - Google Play Help but I'm stuck. Please help.


  • Related Answers
  • Philip Durbin

    I was able to install Google Play Services by browsing to its page at https://play.google.com/store/apps/details?id=com.google.android.gms and then logging in, clicking install, and choosing my phone.

    Come to think of it, I might start installing more apps this way, from the comfort of a desktop browser. :)

    Anyway, I'm able to use the Google+ app again.

    I'm still puzzled by the "No connection" business and having to periodically downgrade Play to Market to install anything from my phone running Android 2.2, but I'm glad I didn't have to root it and install CyanogenMod as suggested by some friends.

  • geffchang

    When I've been unable to log-in to the Google account on an old phone or something, it will often work by logging-in to YouTube with the same credentials.

    YouTube is usually a default installed app. Open it up, go to the account settings and log-in using your GMail credentials. I get no futher problems with logging into GMail. It does it at the same time as YouTube.

    This sorts it out for me. Hope this helps someone.