Nexus 7 says it's charging but it isn't

21
2014-04
  • mariosangiorgio

    I have had a Nexus 7 since September and today something strange happened.

    I plugged it in, as usual, to recharge the battery. It charged up to 36% and now it still says it's charging but it never moves from that percentage.

    How can I fix my device?

  • Answers
  • mariosangiorgio

    I solved my issue using a 2A charger instead of my phone 1A charger or the USB port that provides only 0.5A.

    I am sure I have been able to charge my nexus with all the power sources, but maybe I left it on charge all night long.

  • Andrew Lott

    I'm using a 7" Galaxy Tab (SHW-180S) and this same thing happened with me a few days ago. This is how I solved it:

    1. Remove the battery from the device
    2. Charge your battery from another electric source (I don't remember the device name but most mobile repair shops have them)

    You can also try a hard reset. Changing your charger may also help if it isn't providing enough power to charge Nexus 7.

  • See-Sharp

    Try calibrating (Completely Discharge battery), by playing games or watching videos. Once battery dries try switching your nexus on untill your device refuses to do so. The charge it from a wall charger. See if it works. I have a motorola MB855 , i generally claibrate 5-10 times in a month. That keeps its backup and life healthy.


  • Related Question

    When phone is off and I plug it in to outlet the phone turns on instead of charging
  • Ryan

    This might be hardware but I'm not sure so thought I'd ask.

    Went to plug in to charger at home last night - noticed it didn't charge. Wake up in the morning though and the battery hadn't dropped (or raised)

    At work I have a different charger and same thing seems to be happening.

    I powered off my phone though, removed battery, put back in, and plugged in. This is where it gets strange - instead of showing me a large battery charging which is what use to occur it turns on immediately.

    I checked Software Updates and everything is up-to-date. It is a Samsung Infuse.

    update

    WHILE PLUGGED IN:

    Entered * # * # 4 6 3 6 # * #* to display battery info:

    • Battery Status: Not charging
    • Power plug: Unplugged
    • Battery level: 63%
    • Battery scale: 100
    • Battery health: Good
    • Battery voltage: 3810 mV
    • Battery temperature: 28.0 deg C
    • Time since boot: 11:50

  • Related Answers
  • faomu

    What sticks out to me is that your battery status says "Not charging" Instead of discharging. I feel like your phone may recognize that the charger is plugged in, but may have some error in the battery/phone itself. I feel like your phone may just be translating the charger power directly into the phone itself, and is not able to charge the battery. If this is the case, it IS a hardware issue. Sorry that there isn't much you can do.