root - Orbot not starting on rooted Samsung Galaxy S4 (Verizon)

25
2014-04
  • TronicZomB

    I have recently rooted my Samsung Galaxy S4 (Verizon) using the method found here.

    I am trying to run Orbot(Tor) with the Tor Everything option enabled.

    The application will not get past "Orbot is starting...". I am connected to WiFi and am on Verizon's service.

    Unfortunately I had not tested this prior to rooting so I am not sure if the problems lies with running on an S4 or running on a rooted S4.

    I have tried to uninstall and reinstall Orbot and have not had any luck.

    I have tried to connect to 4G instead of WiFi, no change.

    I have tried to turn off the Request Root Access, no change.

    What is causing Orbot to not connect to the Tor Network?

  • Answers
  • geffchang

    I just installed Orbot awhile ago, and I got it working on my rooted Samsung Galaxy S4. You need to set the proxy for your APN.

    Go to System Settings > More networks > Mobile networks > APN. Open your existing APN, and take note of the settings. You need to make a clone of this APN (so that you will still have the original APN, and have another APN that goes through TOR). Go back to the APNs page, and create a new APN, copying the settings from the other APN.

    Then, set these:

    • Proxy: localhost
    • Port: 8118

    After that, make sure you select the newly-created APN as your new APN. Your network will refresh in a bit. Open your browser and open check.torproject.org. If it was successful, you should see something like this:

    enter image description here

    WARNING: If you use the GMail app (or in my case, Kaiten configured with my GMail), it may detect unauthorized access, and you may be asked to reset your GMail password online.

  • Jeff

    If you deny superuser access it works. At least on my VZW S4 it does.


  • Related Question

    Samsung Galaxy S4 USB Not Recognized by Windows 7
  • Paul Williams

    When I connect my Samsung Galaxy S4 (Verizon) with a USB cable to my work PC that is running Windows 7, my work PC recognizes it immediately. I see all my pictures, music, etc.

    When I connect my phone to my home PC which is also running Windows 7, I get a device named "CD Drive (F:) Verizon Mobile". I see a very short list of folders and files that includes a USB driver (with an autorun) and a few Mac OS folders in it. In Device Manager, this shows up under DVD/CD-ROM drives" with a driver named "SAMSUNG File-Stor Gadget USB Device".

    After a few seconds of looking at these files, Windows removes the device and replaces it with one labeled "SCH-I545". Clicking on SCH-I545, there are no files visible. I have many files and photos on my phone, but I can't see any of them in Explorer. If I right-click SCH-I545 and get Proeprties, I see a battery level, but nothing else.

    Opening Device Manager, I see SCH-I545 in the list of portable devices. The manufacturer of this driver is Microsoft. I have tried uninstalling the driver, unplugging the phone, and plugging it back in, but the same thing happens.

    I have tried downloading and installing the USB driver from the Samsung site, but the same thing happens.

    I have managed to get Samsung Link working to load some files onto my phone, but I would much rather use a file copy mechanism.

    Does anyone have an idea of how I can get my home PC to recognize the phone and let me copy files to and from it?


  • Related Answers
  • Paul Williams

    After searching the Internet for similar issues, I did the following:

    1. I unplugged my phone from the USB cable.
    2. On the home screen, I pressed the bottom left Settings button and chose Settings.
    3. I selected "... More".
    4. I pressed "Developer options" in the list below.
    5. I turned on the Developer options at the top.
    6. Under the Debugging section, I checked "USB debugging".
    7. I reinstalled Samsung Kies.
    8. I started Kies.
    9. After Kies started, I plugged in my phone to the USB cable.

    After connecting my phone with Kies running, the Windows Update form appeared and a new entry was in the list. After the driver installation, everything worked. I don't even have to run Kies first before connecting my phone to get Windows 7 to recognize it. It just works.

    I don't know exactly what series of events caused this to start working, but now I can actually copy stuff to and from my phone. (Yay!)

  • geffchang

    When you connect your Galaxy S4 to the PC via USB, open the notification center and you'll see a message that says something like Connected to USB. Click for more options. Click it, and then select View as camera. After that you, should be able to copy files from the PC to your phone.