4.1 jelly bean - Permission denied on /system/xbin/su when trying to unroot Sony Xperia L

24
2014-04
  • user2687153

    I'm trying to root my Sony XPeria L reading this tutorial The firmaware is 15.0.А.2.17, model C2105, and my Android version est 4.1.2

    Everything was good until step 9, where I get the following error : /system/bin/sh: /system/xbin/su: Permission denied

    So I ran adb.exe from my computer and try to grant my permissions on this file. I tried some chmod 777 su but this is a "Read-only file system"...

    I'm a C# developper and I always used Windows, so Android world is totally new for me. Can anyone help me to avoid this error message ?

    Thanks you !

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    rooting - Officially rooted HTC, denies su permission in Android Emulator app
  • AK4668

    officially rooted from htcdev.com, I followed the instructions step by step and had the screen confirmation that my phone (HTC Sensation XL) is rooted.

    Now when trying to gain super user access through "Android emulator", "Superuser", "Super manager" the permission is denied or the apps cannot detect if the device has been rooted.

    I want to know why root access is denied after the device has been rooted successfully and how to fix this issue, am I missing extra steps or additional settings?


  • Related Answers
  • AK4668

    Thanks to "eldarerathis" for the comment. Basically unlock bootloader does not mean you will have root access to your device. Even though you can install an entire new operating system still rooting your phone must be done inside the OS.

    So if you trying to root your HTC device check unrevoked.com. for other devices I found a reliable tutorial at http://howto.cnet.com/8301-11310_39-20054428-285/how-to-root-your-android/.

    please note unlock bootloader or rooting your device may void your warrantee.

  • geffchang

    First, root your phone. If it denies root access, go to the SuperUser website and download the latest SuperUser and binary packages. After that, reboot in recovery and install the packages. Finally, boot your phone up normally and clear the data of SuperUser. Then, run SuperUser and try updating the binaries and BAAAAM works like a charm!