Samsung Galaxy S4 USB Not Recognized by Windows 7

25
2014-04
  • Paul Williams

    When I connect my Samsung Galaxy S4 (Verizon) with a USB cable to my work PC that is running Windows 7, my work PC recognizes it immediately. I see all my pictures, music, etc.

    When I connect my phone to my home PC which is also running Windows 7, I get a device named "CD Drive (F:) Verizon Mobile". I see a very short list of folders and files that includes a USB driver (with an autorun) and a few Mac OS folders in it. In Device Manager, this shows up under DVD/CD-ROM drives" with a driver named "SAMSUNG File-Stor Gadget USB Device".

    After a few seconds of looking at these files, Windows removes the device and replaces it with one labeled "SCH-I545". Clicking on SCH-I545, there are no files visible. I have many files and photos on my phone, but I can't see any of them in Explorer. If I right-click SCH-I545 and get Proeprties, I see a battery level, but nothing else.

    Opening Device Manager, I see SCH-I545 in the list of portable devices. The manufacturer of this driver is Microsoft. I have tried uninstalling the driver, unplugging the phone, and plugging it back in, but the same thing happens.

    I have tried downloading and installing the USB driver from the Samsung site, but the same thing happens.

    I have managed to get Samsung Link working to load some files onto my phone, but I would much rather use a file copy mechanism.

    Does anyone have an idea of how I can get my home PC to recognize the phone and let me copy files to and from it?

  • Answers
  • Paul Williams

    After searching the Internet for similar issues, I did the following:

    1. I unplugged my phone from the USB cable.
    2. On the home screen, I pressed the bottom left Settings button and chose Settings.
    3. I selected "... More".
    4. I pressed "Developer options" in the list below.
    5. I turned on the Developer options at the top.
    6. Under the Debugging section, I checked "USB debugging".
    7. I reinstalled Samsung Kies.
    8. I started Kies.
    9. After Kies started, I plugged in my phone to the USB cable.

    After connecting my phone with Kies running, the Windows Update form appeared and a new entry was in the list. After the driver installation, everything worked. I don't even have to run Kies first before connecting my phone to get Windows 7 to recognize it. It just works.

    I don't know exactly what series of events caused this to start working, but now I can actually copy stuff to and from my phone. (Yay!)

  • geffchang

    When you connect your Galaxy S4 to the PC via USB, open the notification center and you'll see a message that says something like Connected to USB. Click for more options. Click it, and then select View as camera. After that you, should be able to copy files from the PC to your phone.


  • Related Question

    How to enable a HTC MyTouch 3G Slide USB tether in Windows 7?
  • Unirgy

    I'm trying to use HTC MyTouch 3G Slide for USB tether instead of my old G1, which works perfectly.

    On the first try the ADB driver didn't recognize the phone, but worked fine after adding this to android_winusb.inf in both [Google.NTx86] and [Google.NTamd64]:

    ;T-Mobile MyTouch 3G Slide
    %SingleAdbInterface%        = USB_Install, USB\VID_0BB4&PID_0E03
    %CompositeAdbInterface%     = USB_Install, USB\VID_0BB4&PID_0E03&MI_01
    

    However, when enabling USB tethering, the PID changes to 0E04, and my guess requires to be associated with Remote NDIS driver.

    So I've exported the Remote NDIS using Double Driver, and examined wceisvista.inf file. It says that compatible devices are:

    %WindowsCeDevice%    = RNDIS.NT.5.1, USB\Class_E0&SubClass_01&Prot_03
    

    While the actual device is: USB\Class_02&SubClass_02&Prot_FF

    I've already messed something up by adding the tether mode hardware Ids to the ADB driver.. so now it recognizes it as ADB driver..

    Some more details, on the Slide I have cyanogenmod 6.1.0 installed (Froyo 2.2.1), and the PID changes only when using Wired Tether app (code.google.com/p/android-wired-tether). When switching USB Tether within built-in settings, the PID stays on 0E04. So maybe it is suppose to be associated with ADB driver...

    At this point my knowledge of windows drivers expires.. Anyone has any experience with this? Thanks!


  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.