usb drivers - USB connectivity problems with Nexus 7 2013

19
2014-04
  • Stan

    I've just acquired Nexus 7 (2013) and can't connect it to my PCs. All drivers I have (one from Android SDK, as I'm a developer, and the second from the Android site here, named as latest_usb_driver_windows.zip btw) do not install either under Windows 7, or Windows XP. PC discovers new device as "Nexus 7", but wizard says "could not find the software on your computer" when I specify folder with drivers.

    After some unsuccessful trials, I decided to disable MTP and mass storage modes on the Nexus, just to eliminate these parts of driver - in fact I need only debugging via USB. I enabled the debugging via USB at very beginning, and it shows up in Android's notification bar, but the device does not show up in adb/Eclipse.

    So I switched MTP and mass storage OFF via notification area. This did not help to attach the new device. But now I can't enable either MTP or storage mode back. They are missing in notifications, and they are missing in Settings -> Wireless & Networks -> More, where they are supposed to be.

    So the question number 1: how one can switch MTP and storage mode ON in Android 4.3, specifically on Nexus 7 (2013), other way than via notifications? I saw similar question on the Internet, and the only answer was to reboot the device - in some cases (from time to time!) this worked for someone. I restarted Nexus, but still nothing USB-related shows in settings.

    Also I'd appreciate any clues on how to connect Nexus 7 (2013) to Windows PC? I should mention, that I have Nexus 7 of the first version, and I'm able to debug apps using it, that this first Nexus is connected to the same PC successfully. This brings another problem, because I do not want to lose connectivity with the first device by complete removal of drivers, because I have no guarantee that after this the first device will not become lost in the same manner as the second.

    Thanks in advance.

  • Answers
  • Terenty

    Seems like you need to turn either camera or storage in Settings > Storage > (overflow menu) > USB computer connection (on your Nexus7 2013) to install the adb driver

  • Stan

    I'm posting the solution (as @DanHulme asked me) despite the fact that it's trivial.

    If you already use latest drivers and have no option to reinstall a part or entire system, the only way is to keep trying with what you have again and again.

    I don't know what exactly happened, but after a day of trials (plugging the new device and removing it, pointing the system to the drivers in this way or another) it was finally connected.

    As for the other side-question about MTP, it was actually answered by @eldarerathis in comments: MTP mode can be enabled/disabled in Settings > Storage > (overflow menu) > USB computer connection.

  • Lloigor

    When changing mode and looking at device manager:

    • MTP: i see only the "Nexus 7" device under "Portable Devices", not updatable

    • PTP: i see "Nexus 7" under both "Portable Devices" and "Other devices"

    • none: i see only "unknown device" under "Other devices", not updatable

    So, to fully install drivers, with adb interface, i had to put it first into PTP mode (+debubbing mode). Then update the drivers of the nexus 7 device under "other devices" manually with the google drivers.

    Now put the tablet in MTP mode and update the nexus 7 driver under "portable devices". choose "let me pick...", then "composite..".

    The "Android Composite ADB Interface" now appear under "Android Device".

    et voila..

  • Joshua Gramlich

    I ended up doing a variation of this...the problem I had was the portable/other devices issue. The MTP portion of the driver seemed to be working so I wasn't getting a warning in Device Manager...ergo, I didn't even know that existed until you mentioned it in this post. Updated from the "Portable Devices" bit and it worked right off.


  • Related Question

    usb - Problem connecting Nexus 7 as mass storage device on Windows 7
  • Trevor Sullivan

    I have an Asus Nexus 7 tablet, and was trying to connecting it in MTP (Media Transfer Protocol) mode to my Samsung Series 5 laptop running Windows 7 SP1 Home Premium Edition. I have a bunch of Android development tools installed also, and typically have my devices connected using the ADB (Android Debug Bridge) driver.

    When I first attempted to connect my Nexus 7 to my laptop to use in MTP mode, it simply refused to show up in Windows Explorer. Finally, I figured out that I had to uninstall the ADB device ("Android Phone") from Device Manager and then it would work correctly in MTP mode.

    Any ideas why this is? Is MTP mode trumped by the ADB USB Driver?

    Note: I always had USB Debugging disabled on the Nexus 7, so it wasn't that.


  • Related Answers
  • ruslan

    Although I'm surprised it didn't work in Windows 7 out of the box (it worked on my PC) there is a way to fix it.

    Please open C:\Windows\inf\wpdmtp.inf in Notepad and add following

    ; Nexus 7
    %GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
    %GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4E42&MI_00
    

    In two places - at the end of sections [Generic.NTx86] and [Generic.NTamd64]

    This method will also work on Windows 7 after installing Windows Media Player 11.

  • Andrei0427

    I've had some trouble myself hooking up my nexus 7 with a windows 7 computer, even though I'd figure the device is new, Windows would be able to locate and download drivers itself.

    Its probably some conflict between the two, have you tried first installing the ADB driver after installing the nexus 7 as an MTP device?